JooTC
koajs-logo-silver

koa deprecated Support for generators 문제 해결

nodejs 서버를 구동할 때, 자바스크립트 로그 창에 generators의 지원이 koa v3에서 곧 중단될 것이라는 에러 메시지가 나타나는 경우가 있습니다.

koa deprecated Support for generators will be removed in v3. See the documentation for examples of how to convert old middleware https://github.com/koajs/koa/blob/master
/docs/migration.md server\index.js:29:6

위 에러 메시지는 특정 라이브러리에서 오래된 코드를 사용하고 있어 발생하는 문제입니다. 따라서 어떤 라이브러리를 사용하냐에 따라 달라질 수 있습니다. 저에게 발생했던 문제의 원인은 다음 코드줄에서 있었습니다.

app.use(cors(corsOptions))

이 코드는 koa에서 CORS 옵션을 지정할 수 있는 라이브러리에서 사용되는 코드입니다. 현재 koa의 버전은 2.11.0이며 기존에 설치된 패키지는 koa-cors입니다. 지금은 사용하는데에 큰 지장이 없지만 추후 koa가 3.0 버전이 될 경우 koa-cors 라이브러리를 사용하는 코드에 문제가 발생할 수 있으므로 새로운 라이브러리로 교체해보도록 하겠습니다.

먼저 npm 명령어로 기존의 koa-cors 패키지를 제거하겠습니다.

npm remove koa-cors

우리가 설치해야할 호환 패키지는 @koa/cors 입니다. 이 이름 그대로 npm 명령어로 설치해주겠습니다.

npm install --save @koa/cors

설치가 완료되었으면 기존에 import하던 부분을 변경해주어야 합니다. koa-cors를 import한 코드를 찾습니다.

const cors = require('koa-cors');

이를 다음과 같이 변경해줍니다.

const cors = require('@koa/cors');

이제 모든 것이 완료되었습니다! 서버를 다시 재기동하여 문제가 없는지 확인해보시면 됩니다.

이 포스트가 도움이 되었나요?

댓글 남기기

avatar
error: 경고: 무단 콘텐츠 복사 및 사용을 금지하고 있습니다. 이해해주셔서 감사합니다.